VIP Conduit Now Compatible with Internet Explorer 7.0

This important information is provided by Parker from VIP Conduit concerning the availability of an updated voice chat client that is compatible with Internet Explorer 7.0.

If you have installed Internet Explorer 7 and can’t access the chat rooms, you need to download and install the latest version of the client.  It was updated sometime back but the download was not forced. Just click on the download the Communicator link on the rooms page to obtain a version of the client that will function properly with Internet Explorer 7.0.